Firefox, extensions obsolètes, que faire ?

Ce sujet a 4 réponses, 4 participants et a été mis à jour par jibel jibel, il y a 6 mois et 1 semaine.

5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #5890
    nam1962
    nam1962
    Admin bbPress

     

    Avec l’arrivée de Firefox 57, les extensions devront être au format WebExtensions. Depuis Firefox 54, cela crée au mieux de messages “obsolète” ou “legacy” sur les extensions qui n’ont pas encore migré, au pire des plantages ou disparitions d’extensions.

    En fait les devs bossent (ou pas…) pour complètement réécrire leurs extensions.
    C’est un changement complet de méthode pour eux.
    Les modules “obsolètes” fonctionnent en principe jusqu’à la 57

    FF prend un double risque :
    – s’aligner sur tous les autres navigateurs sur un standard qui vaut.. ce qu’il vaut (un peu une perte de leur esprit d’origine)
    – perdre des extensions massivement adoptées et du coup lasser des utilisateurs.

    Maintenant, il y a déjà eu des marches plus hautes que d’autre pour les extensions et c’était passé et Firefox reste un très grand navigateur.

    Voici quelques trucs pour faire face aux éventuels problèmes liés à cette migration technique :

    1 – Supprimer les extensions qui seront abandonnées (en particulier, pour ceux d’entre vous qui ont suivi mon tuto d’optimisation de Firefox) :

    Allez dans about:addons (à recopier dans la barre d’adresses de Firefox) – onglet Extensions

    Si vous les y voyez, supprimez :
    – Better Privacy
    – Pipelining firefox
    – Roomy Bookmarks Toolbar
    – Self Destructing Cookies
    – Calomel SSL validation

    Better Privacy ne sera pas porté, mais semble t’il n’est plus indispensable.

    Je suis tout à fait triste pour Roomy Bookmarks Bar qui ne sera pas porté, j’ai bien trouvé un truc pour pallier et avoir une barre personnelle avec juste des icônes, mais ça stocke nettement moins de favicons

    2 – Gérer les possibles incohérences temporaires

    Ublock origin peut se désactiver, le problème est connu du dev. Il faut soit :

    – désinstaller ublock origin
    – fermer Firefox
    – rouvrir Firefox et vérifier qu’ublock origin n’est plus là
    – complètement quitter FF (unkillall firefox est le mieux)
    – rouvrir Firefox
    – réinstaller ublock origin

    Si ça ne marche pas, installons à titre intérimaire une version legacy : https://github.com/gorhill/uBlock/releases/tag/1.13.10

    ublock origin est désormais porté en Webextensions

    Rappel, il existe aussi sur Chrome, Opera et Safari

    TabMix plus ne m’inquiète pas tant, mais il semble avoir du retard comme il en a déjà eu. Un mini palliatif est de passer about:config?filter=browser.search.openintab à true et about:config?filter=browser.tabs.loadBookmarksInTabs également à true.

    Vous pouvez aussi installer la version de développement disponible en cliquant sur “latest dev build dans la signature de onemen sur ce lien

    Self destructing cookies est remplacé par cookie autodelete

    Pour gérer la transition, il y a la méthode tout à fait cochon qui consiste à désactiver la gestion de compatibilité : créer dans about:config une nouvelle valeur booléenne extensions.checkCompatibility et la mettre à false et une autre : extensions.checkUpdateSecurity que l’on met aussi à false

    Si vous faîtes cela, pensez à régulièrement vérifier si ce réglage reste nécessaire et si ça plante, démarrez en mode sans echec :

    firefox -safe-mode

    Si votre cas n’est pas dans ce post, regardez cette liste des extentions en migration ou pas. (merci à papy104 du forum Ubuntu) et ici : https://arewewebextensionsyet.com/

    Vous pouvez aussi jeter un coup d’oeil à Waterfox, qui semble vouloir s’affranchir des WebExtensions 😉


    ? Un jeune site que j'aime bien, la ferrari du T-shirt  ...bio en plus : https://goudronblanc.com
    C'est notre mécène ! 🙂

    #5900
    jibel
    jibel
    Modérateur

    Ça vient depuis la new version de F.F. toutes les extensions deviennent obsolètes sans compter avec “le nouvel outil” “https everywhere” qui fout un sacré bordel dans les “modules complémentaires” mais mozilla doit y mettre du sien pour apporter des ennuis avec la nouvelle version … 😎


    ? Toutes les fautes : orthographe, syntaxe, grammaire, vocabulaire, conjugaison...sont ma propriété intellectuelle...néanmoins elles peuvent & doivent être corrigées, modifiées sans qu'on me demande mon avis...Non mais   😎

    #5936
    jlfh0816
    jlfh0816
    Modérateur

    Bonsoir,
    Je suis sous Firefox 55.02 (version 64 bits) et j’avais aussi le message “obsolète” qui s’affichait pour uBlock Origin.
    Je ne me souviens plus où j’ai trouvé l’astuce mais pour enlever ce message, je suis allé sur la page https://addons.mozilla.org/fr/firefox/addon/ublock-origin/
    Là, je vais ensuite tout en bas de la page, je clique sur “canal développement” puis sur “ajouter à Firefox”… et c’est tout. Au redémarrage de Firefox, le message “obsolète” a disparu.
    Je ne sais pas si c’est bien prudent d’installer ainsi la version de développement de uBlock pour Firefox mais, en tout cas, elle fonctionne.

    #5946

    Phil171
    Participant

    Ublock fonctionne bien pour moi (version 55.0.2 – 64 bits). Cette extension avait dispéru à la mise à jour de Firefox. Je n’ai eu qu’à la chercher dans le catalogue et l’installer. Ce n’est PAS une version de développement, apparemment.
    Par contre pour Decentraleyes, elle reste obsolète.
    Pareil pour ImTranslator qui n’existe plus dans le catalogue, dommage, je m’en sers beaucoup et le traducteur de Gogol n’est pas vraiment ergonomique du tout !
    Edith : ImTranslator existe toujours dans le catalogue mais reste obsolète.

    Philippe


    ? Dell Vostro 1510 (portable) 4go RAM, SSD 500Go Samsung.
    Xubuntu 16.04.3 LTS
    xfce4-panel 4.12.0 (Xfce 4.12)

    #6554
    jibel
    jibel
    Modérateur

    Ben voila , j’en suis arrivé a ce que le “quantum”57 soit installé… Ce qui a été fait dans un OS voyager 16.04… Bon tout est OK .. Aujourd’hui je change d’OS pour en ouvrir un de mes autres OSs installés (11) et la grosses surprises quand je lance Firefox je constate que Firefox 56 a été changé pour …. Le “quantum”57 directement sans mes manips.Ah bon, tout y est les PBs avec les “obsolètes”y sont aussi ! D’accord , je suis “client” de mozilla avec mon compte, mais quand même j’aurais du avoir un avertissement pour ce changement automatique des versions de firefox ??? Non? 😉


    ? Toutes les fautes : orthographe, syntaxe, grammaire, vocabulaire, conjugaison...sont ma propriété intellectuelle...néanmoins elles peuvent & doivent être corrigées, modifiées sans qu'on me demande mon avis...Non mais   😎

5 sujets de 1 à 5 (sur un total de 5)

Vous devez être connecté pour répondre à ce sujet.