[Tuto] Désactiver le touchpad pendant la frappe clavier

l’Almanet doLys Gnu/Linux – Open Source – Entreprises Forums L’almanet doLys Open Source [Tuto] Désactiver le touchpad pendant la frappe clavier

Mots-clés : , , ,

Ce sujet a 3 réponses, 2 participants et a été mis à jour par hackoeur hackoeur, il y a 1 an et 8 mois.

4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Messages
  • #4378
    nam1962
    nam1962
    Admin bbPress

    Il est agaçant de voir le curseur de la souris sauter dans tous les sens quand on tape sur le clavier !

    C’est généralement du à nos grosses mains qui traînent sur le Touchpad !

    Pour remédier au problème, tentez dans le terminal un :

    syndaemon -i 1.0 -d -K

    1.0 c’est pour une seconde : vous pouvez ajuster à vos besoins et votre patience !

    Si cela résout votre problème, pour le rendre permanent, passez un :

    printf '[Desktop Entry]\n Name=Keystroke-vs-Touchpad\n Exec=syndaemon -i 1.0 -d -K\n Encoding=UTF-8\n Type=Application\n X-GNOME-Autostart-enabled=true\n OnlyShowIn=XFCE;\n StartupNotify=false\n Terminal=false\n Hidden=false\n Comment=disables touchpad while typing\n GenericName=Keystroke vs Touchpad' > ~/.config/autostart/keystroke-vs-touchpad.desktop

    Vous pouvez améliorer cette commande par vos commentaires ou en contribuant sur github 😉

    Si cela ne fonctionne pas, vous avez peut-etre deux pilotes de Touchpad, vérifiez avec :

    xinput list

    Il faudra alors en désactiver un !


    ? Un jeune site que j'aime bien, la ferrari du T-shirt  ...bio en plus : https://goudronblanc.com
    C'est notre mécène ! 🙂

    #4469
    hackoeur
    hackoeur
    Participant

    Bonsoir nam et et merci de ce tuto.
    Je pensais que tout allait pour le mieux jusqu’à ce que j’installe Xubuntu en mono-boot.
    Là, le curseur n’en refait qu’à sa tête.
    J’ai vérifié par le code précité :

    alpha@no-zenux310a:~$ xinput list
    ⎡ Virtual core pointer	id=2	[master pointer (3)]
    ⎜ ↳ Virtual core XTEST pointer	id=4	[slave pointer (2)]
    ⎜ ↳ Logitech Wireless Mouse	id=12	[slave pointer (2)]
    ⎜ ↳ ELAN1200:00 04F3:3044 Touchpad	id=14	[slave pointer (2)]
    ⎣ Virtual core keyboard	id=3	[master keyboard (2)] ↳ Virtual core XTEST keyboard	id=5	[slave keyboard (3)] ↳ Power Button	id=6	[slave keyboard (3)] ↳ Asus Wireless Radio Control	id=7	[slave keyboard (3)] ↳ Video Bus	id=8	[slave keyboard (3)] ↳ Video Bus	id=9	[slave keyboard (3)] ↳ Power Button	id=10	[slave keyboard (3)] ↳ Sleep Button	id=11	[slave keyboard (3)] ↳ USB2.0 HD UVC WebCam	id=13	[slave keyboard (3)] ↳ Asus WMI hotkeys	id=15	[slave keyboard (3)] ↳ AT Translated Set 2 keyboard id=16	[slave keyboard (3)]
    alpha@no-zenux310a:~$
    

    Celà veut-il dire que j’en ai deux ?
    Si oui, comment en désactiver un et lequel ?
    Peut-être que le temps est temps est-il trop court à 1sec, là aussi je ne sais pas ce qu’il faut bouger du long code.
    Merci de ton aide ou de celle qui viendra.


    ? manjaro-xfce - Voyager-xfce - ...in process

    #4471
    nam1962
    nam1962
    Admin bbPress

    J’ai trouvé çà pour toi : https://ubuntuforums.org/showthread.php?t=2316240


    ? Un jeune site que j'aime bien, la ferrari du T-shirt  ...bio en plus : https://goudronblanc.com
    C'est notre mécène ! 🙂

    #4473
    hackoeur
    hackoeur
    Participant

    Merci nam.
    J’ai refait mon installation et depuis tout va bien, même si je ne sais pas si j’en ai deux ou pas…
    En tout cas pour le moment ça fonctionne.
    Merci encore.


    ? manjaro-xfce - Voyager-xfce - ...in process

4 sujets de 1 à 4 (sur un total de 4)

Vous devez être connecté pour répondre à ce sujet.