[Truc] Calmer les cycles de chargement des têtes des disques WD

l’Almanet doLys Gnu/Linux – Open Source – Entreprises Forums L’almanet doLys Open Source [Truc] Calmer les cycles de chargement des têtes des disques WD

3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Articles
  • #859
    nam1962
    Maître des clés

    Si, comme moi, vous avez un disque dur Western Digital (pour le savoir, passez un

    cat /sys/class/block/sda/device/{model,vendor}

    si vous voyez un WDquelquechose dans le résultat, vous êtes concerné.)

    Le nombre de cycles de chargement et de déchargement des têtes de lecture/écriture risque d’être particulièrement élevé.
    Un procédé, nommé IDLE 3 concu afin d’économiser de l’énergie est beaucoup trop agressif pour Linux (et aussi parfois pour Windows..) et risque de faire exploser le LCC (load cycle count).
    D’ou problèmes de lenteur percue (la tête de lecture se réactive tout le temps) et vieillissement prématuré du HDD, on entend même parfois le cliquetis du dique dur…

    Le mieux est donc de désactiver ce procédé et de laisser votre système gérer plus tranquillement l’affaire.

    Pour cela il nous faut un utilitaire : idle3-tools

    Pour Ubuntu et ses variantes (Xubuntu, Kubuntu, etc) :

    sudo apt-get install idle3-tools

    Sur Manjaro

    sudo pacman -S idle3-tools

    Puis on vérifie l’agressivité du réglage idle3 sur le disque concerné sdX,
    pour connaître X :

    fdisk -l

    ici j’ai mis sda, corrigez si nécessaire. :

    sudo idle3ctl -g /dev/sda

    Si vous voyez 80, c’est bien le réglage aggressif dont je vous parle.

    On désactive idle 3 :

    sudo idle3ctl -d /dev/sda

    Il faut alors eteindre puis démarrer (et non simplement redémarrer)

    Pour vérifier que tout ce soit bien passé, refaites un

    sudo idle3ctl -g /dev/sda

    Vous devez voir :

    Idle3 timer is disabled

    Voilà, cela consommera peut-être un chouïa plus, mais votre disque sera préservé !

    Un jeune site que j'aime bien, la ferrari du T-shirt ...bio en plus : GoudronBlanc

    #4302
    andso
    Participant

    celà concerne une série de disque WD
    et j’ en ai un, et j’ ai appliqué ce patch.
    Faut que je retrouve mes sources
    edit: pas retrouvées, mais si, vous avez un WD:
    sudo smartctl -A /dev/sda | grep "^193"
    sda est possiblement à remplacer par sdb.. en fonction de votre architecture,
    et si le retour est > 1000, bingo!
    source

    #12122
    jibel
    Modérateur/modératrice

    @Tous et nam1962 et andso,
    Voila exactement mon PB, c’est exactement ce qui m’est arrivé. Dans mon vieux PC de 2011 j’avais le disque dur officiel hitachi plus 2 autres disques dur interne et 1 externe de 500Go de WD.
    Depuis l’installe dans la partition étendue de 931Go dans ce nouveau disque dur les deux autres OSs « studio-ubuntu 20.04 lts » et voyager 16.04 (test)
    J’avais auparavant fait les partitions étendues dans chaque disques dur selon leur option 1 tera et 2 tera.
    En installant « openmandriva dans sa partition avec une réussite , je ferme et redemarre mon PC et je contrôle avec gparted si tout est en ordre! Je m’aperçois que cette partition étendue de 931Go a été réduite a 95 Go! ! ! Je n’en revenais pas ? Qu’est-ce qui a bien pu se passer? Alors que depuis mes débuts je fais toujours les mêmes installes sans échec ! 😉
    Ma question est la suivante, puis-je faire une sauvegarde avec déjà-dup d’un des deux OSs installés et transférer la partition cet OS dans une clé USB de 127Go? Ensuite cet OS sera transféré dans sa partition déjà créé dans un autre disque dur présent? merci pour vos réponses 😉 jibel

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.