Optimiser la gestion de la RAM et du Swap sous Linux

l’Almanet doLys Gnu/Linux – Open Source – Entreprises Forums L’almanet doLys Open Source Optimiser la gestion de la RAM et du Swap sous Linux

Ce sujet a 23 réponses, 2 participants et a été mis à jour par deobs deobs, il y a 3 semaines et 1 jour.

9 sujets de 16 à 24 (sur un total de 24)
  • Auteur
    Messages
  • #5654
    nam1962
    nam1962
    Admin bbPress

    …réflexion faite, je me demande si tu n’avais pas un autre fichier d’override.
    que donne :

    ls /etc/sysctl.d -1

    ? Un jeune site que j'aime bien, la ferrari du T-shirt  ...bio en plus : https://goudronblanc.com
    C'est notre mécène ! 🙂

    #5656
    deobs
    deobs
    Participant

    Nope,

    deobs@IdeaPad:~$ ls /etc/sysctl.d -1
    10-console-messages.conf
    10-ipv6-privacy.conf
    10-kernel-hardening.conf
    10-link-restrictions.conf
    10-magic-sysrq.conf
    10-network-security.conf
    10-ptrace.conf
    10-zeropage.conf
    30-tracker.conf
    99-sysctl.conf
    README

    ubuntu-gnome 17.04_64bits
    IdeaPad P500 touch

    #5660
    nam1962
    nam1962
    Admin bbPress

    Tu en as beaucoup plus que moi !
    Ce qui est vraiment curieux c’est que je ne vois toujours pas ce qui a pu causer le blocage de cache_pressure (un fichier > 60-*.conf prend la priorité en principe.)

    Bon, ça aura permis de modifier de manière élégante la série d’instructions.


    ? Un jeune site que j'aime bien, la ferrari du T-shirt  ...bio en plus : https://goudronblanc.com
    C'est notre mécène ! 🙂

    #5665
    deobs
    deobs
    Participant

    Ils sont présent par defaut, aucun ajout de ma part,
    juste les modifs dans 99-sysctl.conf dont on cause dans ce fil :p
    D’ailleur j’ai constatée que /etc/sysctl.d/99-sysctl.conf est un lien vers /etc/sysctl.conf

    ubuntu-gnome 17.04_64bits
    IdeaPad P500 touch

    #5666
    nam1962
    nam1962
    Admin bbPress

    Là c’est logique : c’est comme çà qu’il fait son overrride 😉


    ? Un jeune site que j'aime bien, la ferrari du T-shirt  ...bio en plus : https://goudronblanc.com
    C'est notre mécène ! 🙂

    #5667
    deobs
    deobs
    Participant

    Ca je ne savais pas ! (comme tant d’autres choses d’ailleurs !)

    Apres d’autres lectures, je pense qu’ajouter la commande suivante au 1er post completera bien le peaufinage de la mémoire:
    echo vm.overcommit_memory=2 | sudo tee /etc/sysctl.d/99-sysctl.conf
    par curiosité, quelle est la valeur par défaut sur manjaro et autres distrib si tu as ?

    ubuntu-gnome 17.04_64bits
    IdeaPad P500 touch

    #5668
    nam1962
    nam1962
    Admin bbPress

    Hmm, il y a en principe une gestion automatique de l’allocation de la swap. Je ne connaissais pas ce réglage, mais je ne suis pas tout à fait sûr qu’il soit d’une inocuité totale pour l’utilisateur standard : https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Performance_Tuning_Guide/s-memory-captun.html

    Les curieux pourront tenter, je préfère laisser dans les tutos des réglages très largement testé ! 😉


    ? Un jeune site que j'aime bien, la ferrari du T-shirt  ...bio en plus : https://goudronblanc.com
    C'est notre mécène ! 🙂

    #5669
    deobs
    deobs
    Participant

    je suis entrain de tester le parametre 😉 pour le moment je note ~25% de ram libre en plus.

    This setting is only recommended for systems with swap areas larger than their physical memory.

    Maintenant reste a savoir comment le systeme défini la taille du swapfile, en fonction de la quantité de ram pour permettre une hibernation, a la demande ou prédéfini.

    ubuntu-gnome 17.04_64bits
    IdeaPad P500 touch

    #5674
    deobs
    deobs
    Participant

    bon ce réglage overcommit_memory=2
    est pas compatible avec du gaming en mode déraisonnable 😀
    par contre pour de la bureautique ca me semble indiqué.

    ubuntu-gnome 17.04_64bits
    IdeaPad P500 touch

9 sujets de 16 à 24 (sur un total de 24)

Vous devez être connecté pour répondre à ce sujet.