Souci de GRUB

Mots-clés : 

Ce sujet a 7 réponses, 2 participants et a été mis à jour par nam1962 nam1962, il y a 9 mois et 3 semaines.

8 sujets de 1 à 8 (sur un total de 8)
  • Auteur
    Messages
  • #5820

    Phil171
    Participant

    Bonjour tous,
    Apparemment, j’ai fait une gaffe en essayant d’installer en dualboot W7 et Xubuntu.
    Je ne me rappelle plus quel logiciel j’ai utilisé, mais il me donnait au démarrage la choix durant 10 secondes entre l’un et l’autre OS avec en premier Ubuntu. Je crois que c’était le logiciel natif dans la clé Live USB Xubuntu.
    Bon, suite à cet essai de dual boot réussi, j’ai décidé de revenir à l’essentiel et donc de n’installer que Xubuntu sur mon disque. WIndows ne me servant à rien dans ce cas
    Live USB, essai, installation Xubuntu réussie, redémarrage et là, une page intitulée “GNU GRUB Version 2.02^beta2-36ubuntu2.12” s’affiche avec toujours les options Ubuntu, Memory test, Windows, etc.
    Pensant que le disque était mal effacé, je le formate complètement bit par bit.
    Re-installation de Xubuntu, et même souci à avoir la fenêtre GRUB me donnant le choix de démarrer :
    # Ubuntu
    # Memory test
    # Memory test serial console
    # Ubuntu 16.04.3 LTS sur /dev/sdb1
    # Options avancées pour Ubuntu 16.04 sur /dev/sdb1

    puis au lancement du choix, une attente de plus de 30 secondes sur la page de démarrage Xubuntu.
    Comment enlever cette fenêtre GRUB et ce temps de latence?
    Je suis sur un SSD, ça dépote, normalement !

    Quelle commande terminal ou acion à effectuer pour retrouver un disque “normal”?
    Merci d’avance,
    Philippe


    ? Dell Vostro 1510 (portable) 4go RAM, SSD 500Go Samsung.
    Xubuntu 16.04.3 LTS
    xfce4-panel 4.12.0 (Xfce 4.12)

    #5821
    nam1962
    nam1962
    Admin bbPress

    Oups !
    Pas rencontré ce souci jusqu’ici.
    Pourquoi la 16.04.3 et non la 16.04.1 (Dont le noyau est stable pendant toute la durée de vie de la version) ?


    ? Un jeune site que j'aime bien, la ferrari du T-shirt  ...bio en plus : https://goudronblanc.com
    C'est notre mécène ! 🙂

    #5822

    Phil171
    Participant

    Je pense avoir fait une couillonnerie… lors du dual boot.
    J’ai réussi à réparer le GRUB avec Boot-repair en démarrant sur une Live USB, je n’ai plus cet écran de démarrage avec les options Ubuntu, Mem test etc., mais Xubuntu met encore beaucoup de temps avant d’être actif.
    En lisant divers fils du forum Ubuntu, il pourrait y avoir un souci provenant du lieu d’installation du grub.
    si je fait un fdisk -l
    Ca me retourne pour le disque SSD :

    sudo fdisk -l
    Disque /dev/sda : 465,8 GiB, 500107862016 octets, 976773168 secteurs
    Unités : sectors of 1 * 512 = 512 octets
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x48d902c7
    Périphérique Amorçage Start Fin Secteurs Size Id Type
    /dev/sda1 * 2048 968386559 968384512 461,8G 83 Linux
    /dev/sda2 968388606 976771071 8382466 4G 5 Étendue
    

    J’ai enlevé le swap manuellement il faisait 4Go et n’arrive pas à le réintégrer à la partition principale Linux.
    D’autre part je ne comprends pas n’avoir qu’une partition alors que normalement l’installateur crée au moins trois partitions (en incluant swap).
    Un blème qui n’a pas été résolu en réinstallant via Live USB.
    Serait-ce provoqué par l’image créée et gravée sur la clé?
    Je continue mes recherches.


    ? Dell Vostro 1510 (portable) 4go RAM, SSD 500Go Samsung.
    Xubuntu 16.04.3 LTS
    xfce4-panel 4.12.0 (Xfce 4.12)

    #5824

    Phil171
    Participant

    Bonjour,
    Partiellement résolu via W7.
    Impossible de formater le disque dur SSD correctement via Gparted qui m’envoyait toujours de drôles de messages que je n’ai pas noté.
    Je ne le maîtrise pas trop, cet outil, et il semble peu intuitif et surtout sans aucune aide même en ligne.
    Bref… passage à la moulinette d’Easeus via W7, là, ça a été mieux.
    Création (re-) d’une clé LiveUSB via Rufus. Et je me suis rendu compte que la clé n’avais de lisible par W7 qu’une petite partition dans lequel se trouvait un fichier nommé boot efi ou quelque chose comme ça.
    Sous Gparted cette même clé faisait plus de 55Go alors qu’lle ne fait réellement que 16Go d’usine, bref, passons sur les limites de Gparted.
    Rè-installation via le Live USB sur le disque dur, tout fonctionne apparemment correctement.
    Question :
    Avant d’installer, j’ai créé des partitions ext4, une de 10Go, une de 450Go et le reste en vrac.
    A l’installation, standard, l’installeur m’a tout repris et créé son propre schéma d’implantation.
    Gparted SSD
    Est-ce que je peux essayer (sans gaffer) de récupérer le swap (inutile, c’est un SSD, et l’extended dont je ne comprends pas vraiment ce que c’est…
    Ou dois-je ré-installer mais en préparant manuellement les partitions au lieu de laisser faire l’installateur standard qui ne détecte pas le SSD et installe apparemment comme il veut?
    Merci,
    Philippe


    ? Dell Vostro 1510 (portable) 4go RAM, SSD 500Go Samsung.
    Xubuntu 16.04.3 LTS
    xfce4-panel 4.12.0 (Xfce 4.12)

    #5835

    Phil171
    Participant

    Je m’auto-répond : Ré-installation complète sur SSD à la main et sans swap.
    Mais j’ai toujours la fenêtre du Grub qui apparaît à chaque démarrage, comment l’enlever proprement?
    Est-ce que ce serait propre à la dernière version d’UBUNTU?


    ? Dell Vostro 1510 (portable) 4go RAM, SSD 500Go Samsung.
    Xubuntu 16.04.3 LTS
    xfce4-panel 4.12.0 (Xfce 4.12)

    #5846
    nam1962
    nam1962
    Admin bbPress

    Ce n’est pas très joli, mais le jour ou tu as un éventuel plantage, tu es bien content d’avoir l’affichage grub ! (On peut régler le temps d’affichage dans grub.conf)


    ? Un jeune site que j'aime bien, la ferrari du T-shirt  ...bio en plus : https://goudronblanc.com
    C'est notre mécène ! 🙂

    #5848

    Phil171
    Participant

    Pas grave, réinstallation en 20mn et c’est tout !
    😉
    J’ai trouvé en éditant les paramètres du Grub, je n’ai pas pensé à répondre ici.

    D’ailleurs, ultime question, où puis-je trouver les paramètres de ma session (paramètres perso de visualisation, couleurs, etc.) afin de ne pas trop perdre de temps pour me retrouver dans les mêmes chaussons?
    Merci d’avance,
    Philippe


    ? Dell Vostro 1510 (portable) 4go RAM, SSD 500Go Samsung.
    Xubuntu 16.04.3 LTS
    xfce4-panel 4.12.0 (Xfce 4.12)

    #5858
    nam1962
    nam1962
    Admin bbPress

    Ce sont les dédales de .config
    Graphiquement ce sont les paramètres


    ? Un jeune site que j'aime bien, la ferrari du T-shirt  ...bio en plus : https://goudronblanc.com
    C'est notre mécène ! 🙂

8 sujets de 1 à 8 (sur un total de 8)

Vous devez être connecté pour répondre à ce sujet.