Problème d'imprimante Canon [Résolu]

Ce sujet a 12 réponses, 2 participants et a été mis à jour par Zimba85 Zimba85, il y a 1 an et 9 mois.

13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #3946
    Zimba85
    Zimba85
    Participant

    Bonjour à tous,
    une de mes imprimante Canon MG2100 Séries est branché sur un autre ordinateur sous Kubuntu 14.04. Mon portable sous Xubuntu 16.10 à trouvé cette imprimante mais je ne peux pas imprimer avec car  un message d’erreur me dit qu’elle n’est pas connectée et pourtant elle est sur le même réseau.
    Lorsque tout mes PC étaient sous Kubuntu je n’avais pas ce problème.
    Merci d’avance pour votre aide.


    ? Avec Linux une autre de mes passions
    http://canoneos-1200d.blogspot.fr/2016/07/blog-post.html

    #3950
    nam1962
    nam1962
    Admin bbPress

    Bienvenue !

    Peux tu nous donner le message d’erreur ? Quel pilote as-tu installé sur la Xubuntu ?


    ? Un jeune site que j'aime bien, la ferrari du T-shirt  ...bio en plus : https://goudronblanc.com
    C'est notre mécène ! 🙂

    #3955
    Zimba85
    Zimba85
    Participant

    voici le message d’erreur :

    Page 1 ():
    {'cups_connection_failure': False}
    Page 2 ():
    {'cups_dest': ,
    'cups_instance': None,
    'cups_queue': 'Canon-MG2100-series-2',
    'cups_queue_listed': True}
    Page 3 ():
    

    ? Avec Linux une autre de mes passions
    http://canoneos-1200d.blogspot.fr/2016/07/blog-post.html

    #3956
    Zimba85
    Zimba85
    Participant

    Voici les pilotes de l’imprimante.

    CanonMg2150/cnijfilter-mg2100series-3.60-1-deb
    CanonMg2150/scangearmp-mg2100series-1.80-1-deb
    
    

    ? Avec Linux une autre de mes passions
    http://canoneos-1200d.blogspot.fr/2016/07/blog-post.html

    #3957
    nam1962
    nam1962
    Admin bbPress

    Je n’ai pas d’imprimante Canon, mais il semblerait qu’elle soit gérée par un pilote libre :

    sudo apt update && sudo apt full-upgrade
    
    sudo apt install gimp-gutenprint
    
    

    ? Un jeune site que j'aime bien, la ferrari du T-shirt  ...bio en plus : https://goudronblanc.com
    C'est notre mécène ! 🙂

    #3958
    Zimba85
    Zimba85
    Participant

    je viens d’exécuter les lignes de commandes mais rien de plus. Comment puis-je envoyer des captures d’écran ici?  Merci man1962.


    ? Avec Linux une autre de mes passions
    http://canoneos-1200d.blogspot.fr/2016/07/blog-post.html

    #3973
    nam1962
    nam1962
    Admin bbPress

    Pourquoi des copies d’écran ? Normalement tu as une icone dans l’éditeur pour insérer un image 😉


    ? Un jeune site que j'aime bien, la ferrari du T-shirt  ...bio en plus : https://goudronblanc.com
    C'est notre mécène ! 🙂

    #3975
    Zimba85
    Zimba85
    Participant

    Une capture d’écran est pour montres ce que j’ai comme message d’erreur.

    Une question supplémentaire, j’ai testé Sparky Linux et Linux Mint en live, sur  ces deux versions je pouvais imprimer directement sur l’imprimante connectée sur l’autre PC. Le problème vient-il de ma Xubuntu ?

     width=


    ? Avec Linux une autre de mes passions
    http://canoneos-1200d.blogspot.fr/2016/07/blog-post.html

    #3981
    nam1962
    nam1962
    Admin bbPress

    Hmmm, si les tests live te donnent une imprimante opérationnelle, c’est peut-être qu’il n’y a pas besoin des pilotes installés via les .deb.

    Peut-tu tester après les avoir désinstallés ?

    Sinon, ce n’est pas la xub en soi, mais le kernel qui peut-être coupable. As-tu vérifié le kernel de chaque distrib ?

    <code>uname -a</code>

    ? Un jeune site que j'aime bien, la ferrari du T-shirt  ...bio en plus : https://goudronblanc.com
    C'est notre mécène ! 🙂

    #3982
    Zimba85
    Zimba85
    Participant

    voici

    christian@Christian-ThinkPad-X201:~$ uname -a
    Linux Christian-ThinkPad-X201 4.8.0-37-generic #39-Ubuntu SMP Thu Jan 26 02:27:07 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
    christian@Christian-ThinkPad-X201:~$


    ? Avec Linux une autre de mes passions
    http://canoneos-1200d.blogspot.fr/2016/07/blog-post.html

    #3983
    Zimba85
    Zimba85
    Participant

    man1962,

    pour répondre à toutes ces questions, je viens de mettre Xubuntu 16.04 en live et de tester l’imprimante: elle est fonctionnelle; donc je penses comme toi j’ai du zaper quelque chose à l’install de la 16.10 sur ma clé bootable. Je vais peut-être refaire l’install de / , je ne sais pas si les paramètres de l’imprimante seront en mémoire dans le /home. Que me conseilles-tu de faire? Bien que avec ton tuto je vais assez vite à réinstaller tout en gardant ma configuration actuelle.

    Merci pour ton aide précieuse.


    ? Avec Linux une autre de mes passions
    http://canoneos-1200d.blogspot.fr/2016/07/blog-post.html

    #3984
    nam1962
    nam1962
    Admin bbPress

    Ah, là je ne suis pas forcément très féru !
    A mon sens : avant de réinstaller, désinstalles les deux pilotes avec gdebi.
    Désinstalles aussi le gutenprint.
    Puis jette un coup d’oeil dans ton ~/.config pour voir si il ne traine pas du Canon.

    Question subsidiaire : pourquoi la 16.10 et pas la 16.04 ? (la 16.04.2 est sortie, tu auras le même noyau et la 16.10 n’a plus que quelques mois de support)


    ? Un jeune site que j'aime bien, la ferrari du T-shirt  ...bio en plus : https://goudronblanc.com
    C'est notre mécène ! 🙂

    #3987
    Zimba85
    Zimba85
    Participant

    Me revoilà après les courses, je viens de rentrer et ai vu ton message. Comme tu me le préconise les pilotes des imprimantes sont désinstallés, mais pas le gutenprint, puis j’ai désinstallé les imprimantes : la MG2100 et la MP230, et j’ai réinstallé les imprimantes sans les pilotes et les deux fonctionnent sans avoir rien fait de plus.
    => Question subsidiaire : pourquoi la 16.10 et pas la 16.04 ? (la 16.04.2 est sortie, tu auras le même noyau et la 16.10 n’a plus que quelques mois de support)
    Réponse : j’ai installé la 16.10 à la place de la 16.04 parce qu’elle est plus récente et je pensais y trouver des nouveautés. Ce problème d’imprimante m’avais amené à penser que ma clé était défaillante.
    Donc en résumé, il n’est pas utile (comme je le faisais sous Kubuntu) d’installer les pilotes fournis par Canon.
    Je te remercie pour ton aide et ton jugement je te souhaite un bon week-end. Amitiés.


    ? Avec Linux une autre de mes passions
    http://canoneos-1200d.blogspot.fr/2016/07/blog-post.html

13 sujets de 1 à 13 (sur un total de 13)

Vous devez être connecté pour répondre à ce sujet.