[Résolu] Problème avec Trizen

Ce sujet a 13 réponses, 3 participants et a été mis à jour par jibel jibel, il y a 10 mois et 1 semaine.

14 sujets de 1 à 14 (sur un total de 14)
  • Auteur
    Messages
  • #7058

    obelix1502
    Participant

    Bonjour,
    Étant sous Arch, j’ai un problème avec Trizen qui est codé en Perl.
    Celui-ci remplace yaourt qui n’est plus maintenu.
    En fait, lorsque je veux installer, rechercher, etc. un paquet depuis AUR avec Trizen, j’ai maintenant ce retour de commande (que je n’avais pas au début et je sais qu’il y a depuis eu une màj) :

    Can't locate object method "to" via package "clone" (perhaps you forgot to load "clone"?) at /home/bruno/.config/trizen/trizen.conf line 6.
    Compilation failed in require at /usr/bin/trizen line 290.

    À votre avis que puis-je effectuer comme manip pour résoudre ce problème ?

    #7059
    jibel
    jibel
    Modérateur

    @Obelix
    Il me semble qu’en allant dans le forum d’Arch voir ce qui concerne “trizen” QQu’un pourrait répondre pour savoir ce qui devrait être fait pour installer, misaajourée ton OS …Personnellement je n’ai qu’un OS qui découle d’Arch l’OS MX16 donc j’y vais avec prudence sur des aides d’installations de paquets 😉 😎


    ? Toutes les fautes : orthographe, syntaxe, grammaire, vocabulaire, conjugaison...sont ma propriété intellectuelle...néanmoins elles peuvent & doivent être corrigées, modifiées sans qu'on me demande mon avis...Non mais   😎

    #7062
    nam1962
    nam1962
    Admin bbPress

    Pourquoi dis-tu que Yaourt n’est plus maintenu ? J’avais compris que c’est Pacaur qui ne l’était plus.

    A ce stade je continue avec Yaourt sur mes Manjaro 😉

    Il y a aussi Pacui qui s’appuie sur … Yaourt si je pige bien.

    Pour Trizen, je ne connais pas, mais ai lu qu’il a des dépndances perl, c’est peut-être çà qui coince dans ton Build


    ? Un jeune site que j'aime bien, la ferrari du T-shirt  ...bio en plus : https://goudronblanc.com
    C'est notre mécène ! 🙂

    #7064
    jibel
    jibel
    Modérateur

    @Nam,
    Y-a quand même QQchose qui m’intéresserais… J’ai encore avec moi des live-DVD d’Arch en netinstall, ce qui veut dire que faire une installe de la Arch demande quand même quelques connaissances pour que cette installe d’OS soit faite correctement ….
    Lancer le live-DVD puis faire des trucs, taper dans le clavier lors de l’installe, XXX guest ou autres trucs ce qui devrait faire le début de l’installe en netinstall de +/- 200 Mo et ensuite installer des trucs et machins sans se tromper sur ce qui doit y être ou non ! ! il doit y avoir des manips pour ne pas se tromper, il me semble, car Arch n’est pas si facile a installer 😉 😎 Sauf si je me trompe 😎 😎


    ? Toutes les fautes : orthographe, syntaxe, grammaire, vocabulaire, conjugaison...sont ma propriété intellectuelle...néanmoins elles peuvent & doivent être corrigées, modifiées sans qu'on me demande mon avis...Non mais   😎

    #7068

    obelix1502
    Participant

    Oui nam, je me suis gourré, j’ai commis une erreur : c’est bien pacaur qui n’est plus maintenu, c’est pourquoi on m’a conseillé d’employer trizen qui, c’est vrai, est en perl.

    #7069

    obelix1502
    Participant

    @jibel,

    Oui au début, j’ai galéré pour l’installation. Je m’y suis repris à trois fois mais avec le tutoriel de Bezier, je me suis débrouillé : il est très bien fait. Facilement “trouvable” sur le Net et toujours mis à jour.

    #7070
    jibel
    jibel
    Modérateur

    Il suffit d’aller voir ce que dit Bezier qui lui ne fait que des tests en virtualbox et non en installe dans le D.D.
    Parc contre il est tres bien, si tu te souviens de ton installe et de la cité ICI point par point pour les ceusses qui serait intéressés par la Arch en netinstall de +/- 200 mio dans le live DVD C’est sur qu’on peut y aller en galère et compagnie …Mais faire une installe ou test serait sur de savoir les commandes qui doivent être faites lors du lancement du DVD-live? Sinon c’est galère a n’en plus finir 😉


    ? Toutes les fautes : orthographe, syntaxe, grammaire, vocabulaire, conjugaison...sont ma propriété intellectuelle...néanmoins elles peuvent & doivent être corrigées, modifiées sans qu'on me demande mon avis...Non mais   😎

    #7071

    obelix1502
    Participant

    Ben que ce soit en net-install ou de l’autre manière (600 Mo de différence, je ne vois pas l’intérêt du net-install), les commandes sont les mêmes.
    Juste un petit conseil, pour le partitionnement, je ne me suis pas amusé à les faire en commandes, j’ai utilisé n’importe quelle iso d’une OS Linux et les ai faites avec Gparted. Puis, j’ai tout simplement continué le tutoriel indiqué plus haut.
    Mais une net-install, c’est vraiment se compliquer encore plus la vie, alors que l’iso officielle ne fait que 800 Mo et bootable en USB.

    #7072
    jibel
    jibel
    Modérateur

    De quoi je viens de parler? j’ai lancé ce live -DVD de la arch qui c’est lancé , j’ai cliqué sur la 1er ligne X86x64 qui a lancé le DVD-live ensuite tout défile et bardaf c’est l’embardé…
    j’arrive a la fin===>la $ root archiso …. est présent qui attends que je colle QQchose pour que ce satané début se fasse ou se teste ??? J’attends de savoir ce qui doit y être tapé? Pas de login free , pas de guest, pas de ceci ou cela !! bond’la qu’est-ce qui doit y être ?
    Pour ce qui est de la partition c’est exactement ce que je fais depuis 10 ans que ça soit avec les OSs gnu-linux, debian ou autres OSs, donc…. Ca fait plusieurs fois même en regardant la vidéo de Fred Bezies que je m’agace pour savoir ce qui doit y être tapé…
    Quand j’essaye tout? impossible d’arriver pour que cela continue … C’est ma raison d’en avoir marre, même en allant sur le forum de arch-linux pour “solliciter” une petite et ridicule aide basique…pour qu’enfin cette satané installe se fasse pile-poil 😉 😎


    ? Toutes les fautes : orthographe, syntaxe, grammaire, vocabulaire, conjugaison...sont ma propriété intellectuelle...néanmoins elles peuvent & doivent être corrigées, modifiées sans qu'on me demande mon avis...Non mais   😎

    #7074

    obelix1502
    Participant

    Jibel, je ne comprends pas.

    Je boot sur l’iso archlinux (pas la net-install, pas essayé) et en sélectionnant comme toi x86_x64, j’arrive après le défilement comme tu l’appelles à l’écran que Bezier montre dans son tutoriel. À partir de là, je mets le bon clavier (keymap) etc. Plus de problème. Il n’y avait que les deux premières fois où j’ai eu des problèmes avec les mirroirs, mais en suivant bien le tutoriel, chercher/remplacer avec nano, tout s’est résolu. 🙁

    #7075

    obelix1502
    Participant

    Pour mon problème Trizen, c’est résolu, j’avais comme un con indiqué dans /home/.config/trizen/trizen.conf un répertoire pour les logs que j’avais créé dans mon /home. Or, malgré ce que certains ont pu écrire (pas ici rassurez-vous), il faut laisser par défaut dans le /temp. Mais ICI malgré l’explication, ça ne fonctionne pas, j’obtiens l’erreur décrite plus haut. J’ai donc supprimé mon dossier trizen dans le .conf, désinstallé Trizen, puis réinstallé pour recréer le dossier d’origine dans le .conf et tout fonctionne normalement. 😉

    #7076
    jibel
    jibel
    Modérateur

    @Obelix,
    Ben c’est normal, pour moi aussi avec le DVD-live je suis enfin arrivé a taper “loadkeys fr” puis “cfdisk” la on tombe sur nano (dont je ne me suis jamais servi) pour que ma partition crée soit reconnue, présente, vu par moi…
    C’est alors que je n’ai pas suivi ce qui doit être fait avec “nano” Mais avec le tuto de Fred Bezies en vidéo de l’Arch auquel je suis très intéressé lien que tu as laissé… Surtout qu’il faut absolument suivre ça pas a pas…Même si on loupe QQchose on revient en arrière…Gros avantage avec la vidéo qu’avec la lecture d’un tuto, on loupe une ligne et qu’on oublie de relire trois, quatre fois ou plus…La ça c’est mon intérêt, bizarrement, pour moi ça rentre dans mon cerveau plus rapidement que le souvenir d’un phrase oubliée… et hop la 😉 😎
    Ce genre d’installe, en fait, ne m’a jamais plus des l’instant ou il faut passer avec ce style ,biscottes depuis un certains nombres d’installes 30/40 que j’ai a mon “palmarès”..La je me pose des questions…. 8-(


    ? Toutes les fautes : orthographe, syntaxe, grammaire, vocabulaire, conjugaison...sont ma propriété intellectuelle...néanmoins elles peuvent & doivent être corrigées, modifiées sans qu'on me demande mon avis...Non mais   😎

    #7077

    obelix1502
    Participant

    Jibel,
    Pour ne pas se casser le c.., j’emploie zen install qui est très bien fichu !!
    Aucune erreur. Un script tout ce qui a de plus beau.
    Je viens de le tester sur un portable (assez vieux) qui ne demandais qu’une nouvelle Arch.
    Bezier en parle très bien ici, mais j’avais découvert cela sur le forum Manjaro : ZEN INSTALL ARCH 😉

    Obelix,
    J’ai fais ce dont tu as parlé, installé “zen installer” dans ma clé USB. Effectivement le lancement a été fait, l’installe qui aurait du être en dual-boot a coté de mon autre OS dans le même disque dur a été faite aussi, mais faire l’installe de tout pas a pas, ligne après ligne, cocher ce qui doit l’être, thunderbird, firefox etc etc, la aussi un par un ..OK mais pour la partition pour “arch” celle qui avait été crée par moi, je pensais qu’il n’y aurait pas d’ennuis… Hélas si…Qu’au restart de cette installe finie! alors que normalement les deux OSs installés devaient être dans le menu du lancement
    arch + linux-mint eh bien la, ça a été la big cata…plus de linux-mint reste que l’arch et c’est tout…. 😉
    Heureusement que j’ai mon outil préféré, il s’agit de Boot.Repair.Disk avec cet outil j’ai refais le grub-installe de la linus-mint…. puis supprimer la “arch” zen install”
    Pour ce qui est de la arch ? la c’est assez problématique , pas de synaptic, ni de muon, ni rien, pas des commandes des apt update && apt upgrade
    Sauf qu’il est nécessaire d’avoir fait identique a fred Bezies en virtualbox, pas grand chose a faire avec les commandes, donc pour moi c’est un échec…
    Linux-mint a été relancée comme il le faut, la Arch a été virée et hop-la !! perso je ne crois pas que je continuerais a tester ou installer cet OS…Dommage 😎

    #7080
    jibel
    jibel
    Modérateur

    Ah ! enfin , malgré que j’ai une manjaro que chez eux tu as trouvé cette facilité d’installe, que Fred bezies a sorti cette vidéo “zen install” voila ce qui m’intéresse @ pluche 😉 😎


    ? Toutes les fautes : orthographe, syntaxe, grammaire, vocabulaire, conjugaison...sont ma propriété intellectuelle...néanmoins elles peuvent & doivent être corrigées, modifiées sans qu'on me demande mon avis...Non mais   😎

14 sujets de 1 à 14 (sur un total de 14)

Vous devez être connecté pour répondre à ce sujet.