[RESOLU] Imprimante EPSON XP225

Ce sujet a 44 réponses, 5 participants et a été mis à jour par  Phil171, il y a 1 an et 1 mois.

15 sujets de 16 à 30 (sur un total de 45)
  • Auteur
    Messages
  • #6732

    Lilamas
    Participant

    Je voulais éviter de mixer différents tutos ou différentes solutions pour ne pas mettre davantage le bazar…
    Je tentais de suivre les indications de Phil171.

    #6733

    Phil171
    Participant

    Oui, il ne faut pas trop mixer les différents tutos, c’est ce que j’ai appris (à mes dépends).
    Essaies de te concentrer uniquement sur ton modèle, la XP-225.
    J’ai remarqué deux liens qui pourraient t’aider dans les réponses, celui de Thomas et celui de Jibel
    Thomas pointe sur un lien CCM (Comment ça marche) à la réponse #6720. Cela semble assez simple et complet comme tuto, peut-être à essayer en premier.
    L’autre lien de Jibel est plus complet mais comme il est générique et parle des 3 en 1 ou 4 e 1, ça peut être au final très complexe, mais à essayer !
    A bientôt,
    Philippe


    ? Dell Vostro 1510 (portable) 4go RAM, SSD 500Go Samsung.
    Xubuntu 16.04.3 LTS
    xfce4-panel 4.12.0 (Xfce 4.12)

    #6734

    Lilamas
    Participant

    Phil : bon OK, je vais commencer par ce que conseille Thomas.

    Sinon, je me demandais (attention, les puristes vont hurler !!): quand je bute ainsi, est-ce qu’il ne serait pas plus simple de télécharger les logiciels/pilotes version Windows et de les installer avec Wine ?
    Hormis, j’imagine, le fait que les mises à jour ne seraient pas détectées automatiquement, est-ce que cette méthode peut poser problème ?

    Merci, à plus tard !

    #6735
    jibel
    jibel
    Modérateur

    Logiquement si la fonction de “wine” doit-être installé dans la xubuntu 16.04 sans problème si vous avez suivi les améliorations de xubuntu de Nam point par point, un par un, selon votre ordinateur !
    Que vous avez compris ce qu’il faut faire pour qu’un logiciel de W$ soit installable et utilisable avec wine dans Xubuntu y-a pas de raison…Par contre faire des recherches de logiciels similaires et utilisables dans Xubuntu très identiques avec ceux de W$….


    ? Toutes les fautes : orthographe, syntaxe, grammaire, vocabulaire, conjugaison...sont ma propriété intellectuelle...néanmoins elles peuvent & doivent être corrigées, modifiées sans qu'on me demande mon avis...Non mais   😎

    #6736

    Phil171
    Participant

    Oui, comme dit Jibel, si vous avez installé Wine et que ça marche, “panip’woblem’ pat’won” !!
    Perso, j’ai essayé 3 ou 4 fois d’installer Wine, rien, nada, il ne fonctionne pas !
    Remarque, j’ai aussi un écran noir avec VLC alors que le lecteur Parole fonctionne parfaitement sur des *.MPEG !
    Va savoir !
    Allez, courage “fillette” !


    ? Dell Vostro 1510 (portable) 4go RAM, SSD 500Go Samsung.
    Xubuntu 16.04.3 LTS
    xfce4-panel 4.12.0 (Xfce 4.12)

    #6737

    Lilamas
    Participant

    Bon……….
    J’ai essayé via Wine, cela ne fonctionne pas “nous sommes désolés du désagrément”. J’ai essayé avec 4 drivers différents, tous estampillés XP-225 pour Windows 64 bits. Même résultat pour tous.

    J’ai essayé la méthode indiquée sur le site CCM.
    Le fichier que j’ai téléchargé s’affiche via une interface qui ressemble à Logiciels. Lorsque je clique sur Installer, cela m’affiche un message d’erreur.

    Alors bon, je ne sais pas quoi faire.
    Hier soir, j’ai tenté la première méthode de Phil mais je bloque ici :

    J’ai édité le fichier /lib/udev/rules.d/40-libsane.rules avec les droits d’administration.
    >>> Il est vierge, je ne sais pas si c’est normal ?

    Dans le tuto, ils disent d’ajouter :

    # Epson Stylus CX-xxxx
    ATTRS{idVendor}==”04b8″, ATTRS{idProduct}==”082f”, ENV{libsane_matched}=”yes”

    >>> A quel moment j’inscris la réponse du Terminal que j’ai noté dans un coin (caractéristiques) ?

    De plus, dans l’exemple, il est noté Epson Stylus CX-xxxx, ce qui ne correspond pas au modèle de mon imprimante.
    >>> Mais je ne sais pas comment je dois l’écrire. Epson XP-225 ?

    #6738

    Phil171
    Participant

    Bon, il y a des jours, comme ça, où des imprimantes qui refusent GNU/Linux…
    Sur la méthode (sans garantie !) d’éditer le fichier vide,
    # Epson Stylus CX-xxxx
    ATTRS{idVendor}==”04b8″, ATTRS{idProduct}==”082f”, ENV{libsane_matched}=”yes”
    Tu dois copierc/ coller ces deux phrases et modifier les éléments en croisant les doigts pour que ça marche.
    Tu retires CX- xxx et le remplaces pas XP-225
    tu remplaces {idvendor} pr l’id que tu as noté précédemment, en n’oubliant pas les parenthèses et tu fais pareil pour l’idproduct et libsane.
    Tu sauvegardes le fichiers, tu allumes un cierge et tu testes.
    Il faut que les informations proviennent de ce que tu as noté afin de dire au logiciel libsane quel paramètre utiliser et à condition que tu ais installé libsane et tout ce qui va avec, ce que je penses que tu as fait.
    Le cas échéant, redémarres l’ordinateur par un sudo reboot.
    Mais c’est bien, tu persévères !!
    … Je suppose que tu n’as pas d’autre choix sauf à racheter une imprimante d’une autre marque compatible … 🙂


    ? Dell Vostro 1510 (portable) 4go RAM, SSD 500Go Samsung.
    Xubuntu 16.04.3 LTS
    xfce4-panel 4.12.0 (Xfce 4.12)

    #6740

    Lilamas
    Participant

    Bon, j’ai suivi tes directives.
    Ensuite, j’ai repris à l’étape 3 du tuto

    Mais, je ne dois pas avoir les capacités intellectuelles nécessaires, je ne comprends pas de quel fichier il est question ci-dessous.
    Cela ne correspond pas au fichier précédent /lib/udev etc.

    Il vous faudra encore certainement modifier le fichier /etc/sane.d/epson.conf ou /etc/sane.d/epson2.conf en mode administrateur 1):
    Recherchez la ligne :

    # usb 0x??? 0x???

    Décommentez-la 2) et remplacez les chiffres après le « 0x » par ce que vous avez noté (0x4b8 0x82f).
    Ensuite trouvez et décommentez également les lignes suivantes:

    # usb /dev/usbscanner0
    # usb /dev/usb/scanner0

    Si toutefois cela ne marche toujours pas, pour finir modifiez le fichier /etc/sane.d/dll.conf avec les droits d’administration et changez les lignes:

    #epson
    epson2

    par

    epson
    #epson2

    Pour valider tout ça, rien de tel qu’un petit:

    sudo service saned restart

    Méthode 2: avec Iscan

    Vous devez d’abord télécharger les pilotes correspondant à votre ‘architecture (i386 ou amd64) ici.
    Deux paquets au minimum sont à télécharger:
    iscan_2.xx.x-x~usb0.1.ltdl7_xxx.deb
    iscan-data_1.xx.x-x_all.deb.
    Dans certains cas vous aurez aussi besoin du plugin que vous trouverez ici.
    Installer successivement iscan-data, iscan et iscan plugin.
    Le fichier à modifier est /etc/sane.d/epkowa.conf. Faites-le de la même manière que dans la méthode 1 pour le fichier epson.conf, ainsi que pour les fichiers qui suivent (ajoutez epkowa dans le dll.conf).

    #6742

    Phil171
    Participant

    En lisant le tuto, il demande d’aller vérifier si le scanner est supporté par “sane” ou par Epkowa sur ce lien : ici
    et je lis dans le tableau, vers le bas, qu’il faut utiliser Sane-epson2 et que tout doit fonctionner.
    Donc il faut utiliser la méthode numéro 1: Prise en charge par Sane. Attention, les ports USB3 ne sont pas gérés par libsane !!
    Donc vérifier (par exemple dans un explorateur à part pour être sûr qu’il est là) que le fichier 40-libsane.rules existe dans le répertoire /lib/udev/rules.d/ . Ce fichier se trouve, dans l’explorateur, dans le système de fichiers, pas dans ton “home”.
    Dans l’explorateur, tu cliques sur “Système de fichiers”, puis dans la ligne d’adresse vide tout en haut, tu colles lib/udev/rules.d, là tu chercheras ton fichier “40-libsane…” et tu sauras aussi ce qu’il y a dedans car on peut l’ouvrir mais pas le modifier à ce stade, non ne peut le modifier que lorsqu’on est administrateur, mais c’est un bon moyen de mieux le comprendre.
    Il faut l’ouvrir avec les droits d’administration bien sûr pour le modifier mais pour le voir, pas la peine.

    Tu dis que ça ne correspond pas au fichier prévu, peut-être revenir un peu en arrière dans la procédure pour le créer? Il est dit au dessus qu’il faut les paquets “libsane-extras, sane-utils et xsltproc. Ils sont donc à installer.
    Ensuite, pour décommenter une ligne, il suffit d’enlever le “#” au début.
    Essaies de suivre la procédure point par point et bien lire les lignes du fichier afin qu’elles correspondent à ce qui est dans le tutoriel.


    ? Dell Vostro 1510 (portable) 4go RAM, SSD 500Go Samsung.
    Xubuntu 16.04.3 LTS
    xfce4-panel 4.12.0 (Xfce 4.12)

    #6745

    Lilamas
    Participant

    J’ai effectivement bien fait toutes ces manips.
    Il ne faut pas y voir de la mauvaise volonté ou du bâclage de ma part 😉
    Concernant le fichier /lib/udev/rules.d/, merci pour ta précision, je ne comprenais pas comment le trouver (pour qui vient de Windows, il n’est pas facile de situer ce qui est “home”, “système de fichiers”, etc 😉 )
    Je me suis même offerte le luxe de consulter un site anglais suite à l’affichage du message suivant dans le Terminal : Failed to start saned.service: Unit saned.service is masked (cela s’est affiché lorsque j’ai tapé sudo service saned restart).
    J’ai fait de nouvelles manip pour y remédier. Mais cela n’a pas fonctionné puisque le message s’affiche toujours.
    Rien n’y fait. Mon imprimante imprime du vent…
    Cela doit bien fonctionner, il y a d’autres personnes qui ont la même imprimante que moi et qui ont réussi à l’installer sur Xubuntu…
    Je ne vois pas ce que j’ai pu rater, j’ai suivi toutes les étapes. J’ai vérifié plusieurs fois.

    #6746

    Lilamas
    Participant

    Dans le tuto, il est dit :

    Éditez le fichier /lib/udev/rules.d/40-libsane.rules avec les droits d’administration. Vérifiez d’abord que votre scanner n’y est pas listé. S’il n’y est pas alors ajoutez les deux lignes suivantes au fichier :

    # Epson Stylus CX-xxxx
    ATTRS{idVendor}==”04b8″, ATTRS{idProduct}==”082f”, ENV{libsane_matched}=”yes”

    Les caractéristiques de mon imprimante sont les suivantes :
    Bus 001 Device 008: ID 04b8:08c0 Seiko Epson Corp.

    J’ai donc édité le fichier /lib/udev/rules.d/40-libsane.rules comme ceci :
    # Epson Stylus XP-225
    ATTRS{Bus 001 Device 008:}==”04b8″, ATTRS{ID 04b8:08c0}==”082f”, ENV{Seiko Epson Corp.}=”yes”

    Est-ce correct ?
    Phil, pour la 1ère ligne j’ai suivi ce que tu m’avais indiqué mais je me demande s’il ne faudrait pas plutôt mettre : # Epson Expression Home XP-225. Non ?

    #6747

    Phil171
    Participant

    Peux-tu, dans le terminal, mettre cette commande :
    apt-cache search xxx
    Tu remplace xxx par le nom de ton imprimante qui serait apparemment xp-225, essaies aussi XP-225.
    Donne le retour en copiant/collant les lignes ici.


    ? Dell Vostro 1510 (portable) 4go RAM, SSD 500Go Samsung.
    Xubuntu 16.04.3 LTS
    xfce4-panel 4.12.0 (Xfce 4.12)

    #6748

    Lilamas
    Participant

    Il ne se passe rien en tapant xp-225 et XP-225.
    Alors j’ai tapé XP 225 et xp 225.
    Voici ce que cela a donné :

    delphine@delphine-WE185AA-ABF-CQ5321FR:~$ apt-cache search xp-225
    delphine@delphine-WE185AA-ABF-CQ5321FR:~$ apt-cache search XP-225
    delphine@delphine-WE185AA-ABF-CQ5321FR:~$ apt-cache search xp-225
    delphine@delphine-WE185AA-ABF-CQ5321FR:~$ apt-cache search XP-225
    delphine@delphine-WE185AA-ABF-CQ5321FR:~$ apt-cache search xp225
    delphine@delphine-WE185AA-ABF-CQ5321FR:~$ apt-cache search XP225
    delphine@delphine-WE185AA-ABF-CQ5321FR:~$ apt-cache search xp 225
    libghc-sbv-dev – symbolic Haskell theorem prover using SMT solving
    libghc-sbv-prof – symbolic Haskell theorem prover using SMT solving; profiling libraries
    delphine@delphine-WE185AA-ABF-CQ5321FR:~$ apt-cache search XP 225
    libghc-sbv-dev – symbolic Haskell theorem prover using SMT solving
    libghc-sbv-prof – symbolic Haskell theorem prover using SMT solving; profiling libraries

    #6749
    jibel
    jibel
    Modérateur

    Je ne vois pas ou est le PB pour installer cette imprimante qui si je le crois est une imprimante +/- récente multi-fonctions? (+/- 50€ donc pas très chère) Vous êtes dans votre Xubuntu 16.04 Lts.. version avec laquelle je vous contacte ? Vous devez ouvrir le “gestionnaire de paramètres” dans le gestionnaire vous devez avoir, comme chez moi, “imprimantes” vous devez ouvrir pour l’installer la votre entrer votre mot de passe et voir si cette Epson Xp 225 est présente branchée! Je crois que cette l’installe de cette imprimante demandera si c’est un connexion USB ce qui devrait être le cas . Il n’y a pas de raison pour que votre imprimante ne soit pas présente et fonctionnera … Si c’est comme je l’ai dis un modèle ancien 3/4 ans de production il me semble ?? a vous de voir …
    Pour en être sure , ouvrez synaptic recherchez “xsane et sane” installez les puis une fois installés lancez “xsane” si votre imprimante est connectée elle apparaîtra dans xsane …et hop la…


    ? Toutes les fautes : orthographe, syntaxe, grammaire, vocabulaire, conjugaison...sont ma propriété intellectuelle...néanmoins elles peuvent & doivent être corrigées, modifiées sans qu'on me demande mon avis...Non mais   😎

    #6750

    Phil171
    Participant

    Jibel n’a pas tort et j’avais oublié ça, est-ce qu’elle apparaît dans le gestionnaire?


    ? Dell Vostro 1510 (portable) 4go RAM, SSD 500Go Samsung.
    Xubuntu 16.04.3 LTS
    xfce4-panel 4.12.0 (Xfce 4.12)

15 sujets de 16 à 30 (sur un total de 45)

Vous devez être connecté pour répondre à ce sujet.